VMware View Planner Unauthenticated RCE

By
Febna V M
Published on
16 Jun 2021
Vulnerability

The VMware View Planner is the industry’s first comprehensive methodology for evaluating virtual desktop deployment platforms.VMware View Planner 4.x prior to 4.6 Security Patch 1 is vulnerable to Remote Code Execution if exploited. The logupload web application may allow arbitrary file upload as input validation and authorization control has not been properly set. The file upload and execution will be easier in the View Planner Harness with network access which helps in the remote code execution in the logupload container.

Mitigation / Precaution

  • In order to patch this vulnerability, please install the official patch VMware made available for supported, vulnerable instances.
Automated human-like penetration testing for your web apps & APIs
Teams using Beagle Security are set up in minutes, embrace release-based CI/CD security testing and save up to 65% with timely remediation of vulnerabilities. Sign up for a free account to see what it can do for you.

Written by
Febna V M
Febna V M
Cyber Security Engineer
Find website security issues in a flash
Improve your website's security posture with proactive vulnerability detection.
Free website security assessment