LinuxKI Toolset 6.01 Remote Command Execution

By
Anandhu Krishnan
Published on
16 Jun 2021
Vulnerability

Remote Code Evaluation will result in the entire web application and web server being compromised.Here RCE is performed over LinuxKI Toolset 6.01 .LinuxKI versions 6.0-1 and earlier are subject to remote code execution, which has been fixed in version 6.0-2.

Impact

A lot of information disclosure can happen. It is possible to change certain system files or information, but the attacker has no control over what can be changed, or the scope of what the attacker can affect is restricted.There is a decrease in efficiency or a disruption in the availability of resources.

Mitigation / Precaution

  • In order to patch this vulnerability, please install the official patch LinuxKI made available for supported, vulnerable instances.
  • We suggest that you update LinuxKI Toolset greater than 6.01 in order to fix this vulnerability.
  • If you are using LinuxKI Toolset 6.01 , upgrade to LinuxKI Toolset 6.0-2.
Automated human-like penetration testing for your web apps & APIs
Teams using Beagle Security are set up in minutes, embrace release-based CI/CD security testing and save up to 65% with timely remediation of vulnerabilities. Sign up for a free account to see what it can do for you.

Written by
Anandhu Krishnan
Anandhu Krishnan
Lead Engineer
Find website security issues in a flash
Improve your website's security posture with proactive vulnerability detection.
Free website security assessment