LARAVEL less than or equal to V8.4.2 DEBUG MODE - REMOTE CODE EXECUTION

By
Manieendar Mohan
Published on
16 Jun 2021
Vulnerability

Laravel is a web application framework with a syntax that is both eloquent and elegant. This framework is vulnerable to remote code execution when it is run on debug mode. In debug mode, the framework displays the verbose error messages that include stack traces. This helps the attacker to initiate remote code execution.

Mitigation / Precaution

  • In order to patch this vulnerability, please install the official patch made by the vendor available for supported, vulnerable instances.
  • Don’t enable debug mode in production
Automated human-like penetration testing for your web apps & APIs
Teams using Beagle Security are set up in minutes, embrace release-based CI/CD security testing and save up to 65% with timely remediation of vulnerabilities. Sign up for a free account to see what it can do for you.

Written by
Manieendar Mohan
Manieendar Mohan
Cyber Security Lead Engineer
Find website security issues in a flash
Improve your website's security posture with proactive vulnerability detection.
Free website security assessment