Jolokia XSS

By
Manieendar Mohan
Published on
20 Dec 2021
Vulnerability

Jolokia is a JMX-HTTP bridge giving an alternative to JSR-160 connectors. It is an agent based approach with support for many platforms. The Jolokia agent version 1.3.7 in the HTTP servlet has an XSS vulnerability that allows an attacker to run malicious javascript in the victim’s browser.

Solution:

We suggest that you upgrade to version ```org.jolokia:jolokia-jvm:1.4.0, org.jolokia:jolokia-core:1.4.0``

Automated human-like penetration testing for your web apps & APIs
Teams using Beagle Security are set up in minutes, embrace release-based CI/CD security testing and save up to 65% with timely remediation of vulnerabilities. Sign up for a free account to see what it can do for you.

Written by
Manieendar Mohan
Manieendar Mohan
Cyber Security Lead Engineer
Find website security issues in a flash
Improve your website's security posture with proactive vulnerability detection.
Free website security assessment