ILO4 Authentication bypass

By
Rejah Rehim
Published on
15 Jun 2021
Vulnerability

HPE’s Integrated Lights-out 4 (iLO 4) controllers prior to version 2.54 are affected by an authentication bypass and code execution vulnerability. This vulnerability is triggered by a buffer overflow attack in how the web server handles the Connection HTTP header.

Impact

An attacker can create an administrative account due to unrestricted access to the REST API and also can perform dangerous actions such as power off a server remotely, triggering virtual media, or altering the underlying OS.

Mitigation / Precaution

  • We recommend you to upgrade to HPE Integrated Lights-out 4 (iLO 4) firmware version 2.53 or newer
Automated human-like penetration testing for your web apps & APIs
Teams using Beagle Security are set up in minutes, embrace release-based CI/CD security testing and save up to 65% with timely remediation of vulnerabilities. Sign up for a free account to see what it can do for you.

Written by
Rejah Rehim
Rejah Rehim
Co-founder, Director
Find website security issues in a flash
Improve your website's security posture with proactive vulnerability detection.
Free website security assessment