AppServ Open Project 2.5.10 and earlier XSS

By
Febna V M
Published on
10 Jan 2022
Vulnerability

Description

AppServ is an open-source software installer package for Windows, and it includes Apache Web Server Version 2.4.25, PHP Script Language Version 5.6.30 & 7.1.1., MySQL Database Version 5.7.17.

AppServ Open Project 2.5.10 is vulnerable to Cross-site scripting (XSS) vulnerability in index.php in AppServ Open Project 2.5.10 and earlier allows remote attackers to inject arbitrary javascript code or HTML via the appservlang parameter.

Recommendation

  • Update AppServ Open Project to the latest version.
Automated human-like penetration testing for your web apps & APIs
Teams using Beagle Security are set up in minutes, embrace release-based CI/CD security testing and save up to 65% with timely remediation of vulnerabilities. Sign up for a free account to see what it can do for you.

Written by
Febna V M
Febna V M
Cyber Security Engineer
Find website security issues in a flash
Improve your website's security posture with proactive vulnerability detection.
Free website security assessment